Path problems with API for OS X

Posted in General by Fanis Wed May 06 2015 15:45:28 GMT+0000 (Coordinated Universal Time)·1·Viewed 2,607 times

I encountered several problems trying to make the examples work for Mac OS X. I'm running Yosemite and I have installed the latest version of Xcode. I tried both the Xcode and QT versions and always got the exact problem when trying to run the examples: dyld: Library not loaded: libISKN_API.1.dylib Referenced from: ... Reason: image not found Clearly, the path for the ISKN library was not correct. I moved libISKN_API.1.dylib to the Contents/MacOS subdirectory of the generated application file (e.g., SlateTheremin/Contents/MacOS/) and the problem was resolved. But I got a new error! dyld: Library not loaded: /Users/ISKN/Qt/5.4/clang_64/lib/QtCore.framework/Versions/5/QtCore Referenced from: .../ Reason: image not found So the library assumes that QT has been installed under the home folder user named ISKN! So I created this path and copied the QtCore directory there, and now it works! Of course, this is not a good solution. Given that I have not experience with QT programming, I waisted a whole day trying to identify the problem. Let us know when you resolve this issue or please let me know if I'm doing something wrong. fanis
May 7, 2015

Hi Fanis,

Thanks for reporting the problem.

You did not do anything wrong, we just never expect Qt/Clang to link QtCore with an absolute path, it seems to be a specific problem with Qt on OS X.

This will be fixed in the next release that will come out soon.

If you want to solve this problem faster on your own, you can change this path in the dylib by using the ‛install_name_tool‛ command line.
You'll find some examples on this page :

Hope this will help.
Let us know if you need anything and have fun!

Steven for the iskn team.

Markdown is allowed