Wrong dylib files for OS X

Posted in General by Chipp Jansen Fri Feb 16 2018 17:01:18 GMT+0000 (Coordinated Universal Time)·7·Viewed 349 times

I am unable to properly run the OS X examples for MyFirstTest or MagicBeep with the x64_MACOS_Clang. I am using XCode 9.2 on macOS High Sierra. Originally, I had the same x86_64 architecture problem as others with libISKN.dylib. I did verify that I was compiling with the x86_64 flag in Xcode. It turns out, in the latest ISKN_API, the files: libISKN_API.dylib libISKN_API.1.dylib libISKN_API.1.0.dylib are all text files with the contents "link libISKN_API.1.0.0.dylib". I believe they were symbolic links, but in the release of the API, they did not properly package. After replacing those files with a copy of libISKN_API.1.0.0.dylib, I was able to get the Xcode Project to BUILD, but it does not run, I get this error: dyld: Library not loaded: libISKN_API.1.dylib Referenced from: /Users/chipp/Library/Developer/Xcode/DerivedData/MagicBeep-ffrlbouopwngvyghmwjkipttstle/Build/Products/Debug/MagicBeep.app/Contents/MacOS/MagicBeep Reason: image not found I have tried copying ALL of the .dylib files into the Contents/MacOS of the above running application, and get the same error. I also tried including the .dylib files in the Embedded Binaries tab of the Xcode > General setting in the project, and get the same error. I have tried the above as well with the libISKN_APId* (i.e. the Debug? version of the library), which did not have the "link ..." file contents problem. I get the same run-time error as above, but referencing the "ibISKN_APId.1.dylib". Please let me know if there is anything that I am missing, thanks!
Feb 19, 2018

Hi,

We are sorry to hear that. we did test the API for x64_MACOS_Clang and we had the same error. You did well but the current API is out of date that why you have not been able to solve the problem.

We are actually working on a new API version for OSX and the all others platforms. We will be able to send you a version as soon as the problem is solved. we will keep you informed.

Rabeb for iskn team.

Feb 19, 2018

Thanks for getting in touch!

Any idea when the new API should be released? I am most interested in the Linux Version which also has some issues.

Feb 20, 2018

Hello again,

The new API is scheduled for April and there will be a version for Linux.
We will keep you updated as developement progress.

Rabeb for iskn team.

Sep 12, 2018

Any update on this?

Sep 17, 2018

Hello Rabeb,
I am having the same issue running the example with XCode Version 9.0.1 (9A1004) on OSX SIerra 10.12.6.
Is there any update on this issue?
I would need to start working on this quite soon and I am stuck.

Thanks

Sep 19, 2018

Hello Antonio,

You can try to put the library files ( libISKN_APId.1.0.0.dylib with the symbolic links)
into the lib folder : /usr/local/lib. In fact Xcode use sometimes /usr/local/lib as a default search path.

Rabeb for the iskn team.

Sep 20, 2018

great!
it seems to work.
thank you very much.
:)

  
Markdown is allowed